Thanks to all who attended today's OpenText Support Community Event: Customer Contributions to Knowledge Program.

A recording of the event and the next steps to start your contributions can be found here:

Customer Contributions to Knowledge Presentation

Let's get started!

New DQL Editor

Description

The DQL Editor gives xCP developers and Tech Support a convenient environment for

working with DQL and speed up the development and maintenance time for xCP applications.

Highlights

  • Simple and intuitive Eclipse-like UI

  • Easy configuration - no need to have Documentum
    installed on the editor machine.

  • Results of DQL queries are represented in tabular way.
    You can copy and paste the vaules in table cells and navigate the cells.

  • Export of DQL result set to CSV - especially
    usefull when working with customers.

  • Syntax highlighting

  • Auto completion - the editor offers suggestions for known
    DQL types and reserved words.

  • History - you can give a short alias to your most useful queries.
    By typing the short alias in the editor pane you will get your
    complex query. Auto completion also exists for the aliases.

User

The target users are:

  • Tech Support
  • xCP Developers
«1

Comments

  • edited November 2010

    Tried it last night and deleted it!!!

    Problem: No main file so could not launch

    Personally, I do not like that you have included dfc.jar. log4j.jar, ??? in your package. These are already distrubted in base DFC, so why are you packaging them?

    Some folks like that everything is in one package, personally it annoys me.

    I perfer to assume that if you are working with Documentum you should have a copy of DFC locally. More importantly that copy will most likely be the correct version for the runtime environment. Another plus of my strategy.... if you do need to ask for DFC jar files, then you probably should not be using this tool or any other!!!!

  • edited November 2010

    I tried it as well - you just double click the jar file, and open it with Java SE!!!!

    1. It works exactly as it says it will.

    2. It also works on my machines where I have no Documentum installation at all (which is great for me)

    3. Works in LAB environments as well

  • troletrole Oleg Terner
    edited November 2010

    Excellent and very useful tool! Thank you!

  • LeonovLeonov Pavel Leonov
    edited November 2010

    Very useful tool.

    Especially liked the “History” feature – great time saver!

    Here is my wish list for DQL editor tool:

    1. Implement multiple queries running with ‘go’ command or some other operator, in this case should be added two different run commands: run whole script and run only current query (between ‘go’ 2 operators) like it works in PL/SQL editor
    2. Read/write queries to file
    3. Add multiple editors feature
    4. Use monospaced font
    5. Force code coloring in case pasting a code from clipboard
  • edited November 2010

    Thanks,

    my wishlist the same as Leonov's )

  • edited November 2010

    Very useful utility. i think we all been waiting for such tool. it is good indeed that someone finally took initiative to create one. on one hand it can  really help engineers and SIs to be more productive and can shorten customer project development. on the other hand it will make our customer support more effective since the utility makes it easy task to understand what's going on in customer's repository.

    well done.

  • edited April 2011

    Seems to hang if I try to flatten a query with repeating attributes by placing r_object_id as first column name?

    E.g.

    select r_object_id, object_name, authors from lp_document where document_number = 'A03477578'

    Makes it pretty unusable. :-(

  • edited April 2011

    Generally, repeating attributes should not be the problem.

    May be there are a lot of records in lp_document object type and it just takes

    alot of time to execute the query and bring the result.

    1.

    Were you able to run the same query through Documentum IDQL ?

    2.

    How many objects do you have in lp_document object type ?

  • edited April 2011

    Hi, it runs in under a second in Documentum Administrator DQL tester. I tried various repeating attributes, keywords, authors, r_version_label they all had the same problem.

    i suspec the result comes back but the app dies?

    thanks

    Phil.

  • edited April 2011

    The following query (with repeating attribute "authors")  executes

    successfully through DQL Editor  -

    select r_object_id, object_name, authors from dm_document where object_name = 'doc-name'

    Anyway, I will try to test it more in order to understand what caused the problem ...

  • edited October 2012

    The project is still alive?

  • edited October 2012

    Freejin, why cant you just use Repoint?

  • edited October 2012
  • edited October 2012

    It is still alive, we didn't add any features lately, but we did it compatible with D7 release.

  • edited October 2012

    People,

    thanx a lot for your replies. I would like to try DQL Editor and Repoint. As for me i am used dqMan (dqMan Extended too) and DQLTester before but trouble with cyrillic is still actual. We are thinking about maybe developing our own tool..

  • edited December 2012

    Hello Guys,

    Today I downloaded this dump and I configured dfc.properites file with host, port [default:1589], repository, username & password. I launched DQL editor then it’s shows error occurred.

    I am able to see below logs in log4j.properies file.

    Can you help me on how to connect docbase?

    Please treat me as high priority.

    Thanks in advance.

    DfDocbrokerException:: THREAD: main; MSG: [DFC_DOCBROKER_REQUEST_FAILED] Request to Docbroker "tcdcmcont01p:1589" failed; ERRORCODE: ff; NEXT: null

                    at com.documentum.fc.client.DfDocbrokerException.newRequestFailedException(DfDocbrokerException.java:12)

                    at com.documentum.fc.client.impl.connection.docbroker.DocbrokerConnection.<init>(DocbrokerConnection.java:30)

                    at com.documentum.fc.client.impl.connection.docbroker.DocbrokerConnectionFactory.newDocbrokerConnection(DocbrokerConnectionFactory.java:27)

                    at com.documentum.fc.client.impl.docbroker.MapBuilder.issueRequest(MapBuilder.java:27)

                    at com.documentum.fc.client.impl.docbroker.ServerMapBuilder.getDataFromDocbroker(ServerMapBuilder.java:76)

                    at com.documentum.fc.client.impl.docbroker.ServerMapBuilder.getMap(ServerMapBuilder.java:35)

                    at com.documentum.fc.client.impl.docbroker.DocbrokerClient.getServerMap(DocbrokerClient.java:152)

                    at com.documentum.fc.client.impl.connection.docbase.ServerChoiceManager.updateServerChoices(ServerChoiceManager.java:159)

                    at com.documentum.fc.client.impl.connection.docbase.ServerChoiceManager.updateServerChoicesIfNecessary(ServerChoiceManager.java:148)

                    at com.documentum.fc.client.impl.connection.docbase.ServerChoiceManager.getServerChoices(ServerChoiceManager.java:47)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnection.getServerChoices(DocbaseConnection.java:269)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnection.establishNewRpcClient(DocbaseConnection.java:223)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnection.open(DocbaseConnection.java:122)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnection.<init>(DocbaseConnection.java:96)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnection.<init>(DocbaseConnection.java:58)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnectionFactory.newDocbaseConnection(DocbaseConnectionFactory.java:26)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnectionManager.createNewConnection(DocbaseConnectionManager.java:174)

                    at com.documentum.fc.client.impl.connection.docbase.DocbaseConnectionManager.getDocbaseConnection(DocbaseConnectionManager.java:104)

                    at com.documentum.fc.client.impl.session.SessionFactory.newSession(SessionFactory.java:23)

                    at com.documentum.fc.client.impl.session.PrincipalAwareSessionFactory.newSession(PrincipalAwareSessionFactory.java:44)

  • edited December 2012

    Hello,

    Is it so necessary for You to to use DQL editor? Don;t spend a lot of time for fixing, try dqMan - it is free.

    WBR

  • edited December 2012

    Thanks, but admin rights should require to use DQman, right? I am having Windows 7 Enterprise OS on my laptop. I have DQMan 5 dump on my system, however If I click on the exe file, then it’s asking admin credentials. So please help me which tool I should use for DQLs & APIs without admin rights.

  • edited December 2012

    Try to use Repoint (it is not need to install it). It is require only dfc.jar, dfc.properties and seems to Eclipse installed (last one please check by starting before Eclipse inst.)

    Cheers

  • edited December 2012

    Thanks Denis.

    I downloaded standalone Repoint [without eclipse]and I have configured dfc.properties & dfc.jar files, however repoint is not working properly.

    I am getting below massage, if I ran simple DQL.

    “Can’t find a docbase against which you run the query.”

    Even I am able to see below errors in the log4j file.

    0 [main] ERROR com.documentum.fc.common.impl.logging.LoggingConfigurator  - Problem locating log4j configuration

    16 [main] WARN com.documentum.fc.common.impl.logging.LoggingConfigurator  - Using default log4j configuration

    265 [Thread-1] ERROR com.documentum.fc.common.impl.preferences.PreferencesManager  - [DFC_PREFERENCE_LOAD_FAILED] Failed to load persistent preferences from null

    1. java.io.FileNotFoundException: dfc.properties

                    at com.documentum.fc.common.impl.preferences.PreferencesManager.locateMainPersistentStore(PreferencesManager.java:378)

                    at com.documentum.fc.common.impl.preferences.PreferencesManager.readPersistentProperties(PreferencesManager.java:329)

                    at com.documentum.fc.common.impl.preferences.PreferencesManager.<init>(PreferencesManager.java:37)

                    at com.documentum.fc.common.DfPreferences.initialize(DfPreferences.java:64)

                    at com.documentum.fc.common.DfPreferences.getInstance(DfPreferences.java:43)

                    at com.documentum.fc.common.DfFileWatcher.getConfigCheckInterval(DfFileWatcher.java:31)

                    at com.documentum.fc.common.DfFileWatcher.run(DfFileWatcher.java:54)

    2465 [main] ERROR com.documentum.fc.client.security.impl.IdentityManager  - [DFC_SECURITY_IDENTITY_INIT] no identity initialization or incomplete identity initialization

    DfException:: THREAD: main; MSG: ; ERRORCODE: ff; NEXT: null

                    at com.documentum.fc.client.security.impl.JKSKeystoreUtil.creteNewKeystoreFile(JKSKeystoreUtil.java:425)

                    at com.documentum.fc.client.security.impl.JKSKeystoreUtil.createNewKeystore(JKSKeystoreUtil.java:209)

                    at com.documentum.fc.client.security.impl.DfcIdentityKeystore.applyDfcInitPolicy(DfcIdentityKeystore.java:95)

                   

                    at org.eclipse.core.launcher.Main.run(Main.java:977)

                    at org.eclipse.core.launcher.Main.main(Main.java:952)

    Caused by: java.io.IOException: Access is denied

                    at java.io.WinNTFileSystem.createFileExclusively(Native Method)

                    at java.io.File.createNewFile(Unknown Source)

                    at com.documentum.fc.client.security.impl.JKSKeystoreUtil.creteNewKeystoreFile(JKSKeystoreUtil.java:412)

                    ... 60 more

    2574 [main] WARN com.documentum.fc.client.security.internal.RegistrationMgr  - [DFC_SECURITY_GR_PUBLICATION_FAILED] Publication of DFC instance with global registry failed

    DfException:: THREAD: main; MSG: [DFC_BOF_GLOBAL_REGISTRY_NOT_CONFIGURED] A global registry is not configured; ERRORCODE: ff; NEXT: null

                    at com.documentum.fc.client.security.impl.DfcIdentityPublisher.<init>(DfcIdentityPublisher.java:51)

                    at com.documentum.fc.client.security.internal.RegistrationMgr.register(RegistrationMgr.java:34)

                    at com.documentum.fc.impl.RuntimeContext.<clinit>(RuntimeContext.java:191)

                    at com.documentum.fc.client.DfClient.<clinit>(DfClient.java:772)

                    at com.documentum.devprog.eclipse.common.PluginHelper.<clinit>(PluginHelper.java:125)

                    at com.documentum.devprog.eclipse.tree.DocbaseTreeView.createActions(DocbaseTreeView.java:338)

  • edited December 2012

    not at all.

    it seems that Repoint can't read dfc.properties file. Check permissions etc.

    I have just tried Repoint in my  Windows 7 - it is opening it's interface but i have errors that points to the absence of Eclipse classes (GUI errors)

  • edited December 2012

    Are you running on 64bit Win 7?  If so, you will need 64bit JRE in order for Repoint to work.

  • edited December 2012

    @Denis-I don’t find any permission issues on dfc.properties file and seems good. What could be the issue here? I am able access DQL Editor tool with same configuration files from different folder structure.

    @Johnny- Yup, running on win 7 [with 64 bit] and I don’t think my system has any JRE version. I can install from application catalog, since I don’t have admin rights on my system. Getting admin rights is very difficult. I can see Java (TM) 6 Update 29 & Java (TM) 6 Update 30 softwares are available in application catalog for win7,  so which one I should install? I believe If I install Java, then JRE also should come? OR Do I need to install JRE 64 bit explicitly? 

    Please advise me on the same. Thanks.

  • edited December 2012

    I installed JRE [64 bit] on my system, however repoint is not working. It’s showing “No DocBrokers are configured”.

    I had setup dfc.properties  & dfc.jar files. Do I need to set-up any other configuration files?

    Did I miss anything?

  • edited December 2012
    @Denis-I don’t find any permission issues on dfc.properties file and seems good. What could be the issue here? I am able access DQL Editor tool with same configuration files from different folder structure.

    do you run Repoint via 'Run as Administrator'? Or you are not able to use this function?

  • edited December 2012

    No, I ran as simple, but after that tool launched, then If I click on add repository to the Tree view, then it’s throwing “No DocBrokers are configured” error. Did I miss anything here?

    I can't use Admin option, since I don't have Admin rights on my laptop.

  • edited December 2012

    even no possibility to open DA and do your job in DQL, API sub-menues? Or ,maybe you can connect to the Documentum Server manager?

    Sorry, I don't spend a lot of time for configuring repoint, we have our own another service tool.

  • edited December 2012

    hi reddy,

    it seems that in any of the tools you are able to connect to your docbase.

    maybe you didn't configure it correctly?

  • edited December 2012

    You could try samson which comes with the content  server.

    Better to use dqman  even though it requires admin rights as it is a good tool.

  • edited December 2012

    I prefer DQL Editor for now.

«1
Sign In or Register to comment.