Today we are pleased to announce docker support for TeamSite, LiveSite, and OpenDeploy version 16.3, about 2 to 3 weeks ago we had released support version 16.2. This release marks our second release of docker support for TeamSite, LiveSite, and OpenDeploy.

Please join us on this journey and contribute by engaging on a special focus forum: TeamSite, LiveSite, and OpenDeploy - Docker. To obtain the automation for Docker, log in to MySupport, navigate to Product>OTDN>Web Content Management (TeamSite)>TeamSite, LiveSite, OpenDeploy> Docker Automation>16.3.

A new bit of oddness with iw.cfg on 8.2 with server_locale

Set server_locale in iw.cfg to UTF-8. Upon restarting teamsite, it inserts a line setting it back to Latin1.

Before restart:

[iwserver]
server_locale=English_UnitedStates.UTF-8@Default;

After restart:

[iwserver]
server_locale=English_UnitedStates.Latin1@Default;
server_locale=English_UnitedStates.UTF-8@Default;

This is munging any character with diacritics, which is **** our install big time.

Comments

  • Adding: TS 8.2.0.4, Solaris10, OS is set to utf-8

  • Poking around on this, came across this in the 8.0 docs:

    The iw.cfg file contains a server_locale entry in the [iwserver] section. The entry specifies the locale in which current execution of the TeamSite server (iwserver) runs. For example:

    [iwserver]
    server_locale=English_UnitedStates.MS1252 (Windows)US-ASCII (Unix)@Binary;

    This setting is automatically created in the iw.cfg file when iwserver is started. The native/system locale is determined by reading the LANG environment variable (Unix)/System Locale setting in the Regional Settings control (Windows). Once the server_locale setting exists in the iw.cfg file, it is used to determine the TeamSite server’s native/system locale at every invocation of iwserver. If this setting is not present, iwserver determines its locale from the LANG environment variable (Unix) /System Locale setting in the Regional Settings control panel (Windows).

    While this setting can be user-modified, it is designed to serve as reference as to the locale in which iwserver is currently running. If you have a situation where you want to force iwserver to run in a particular locale (independent of the LANG environment variable (Unix)/System Locale setting (Windows), you can stop the TeamSite server, manually edit the server_locale line, then restart the TeamSite server.

    Which is not working as expected. Our OS language is set to UTF-8.

    root@irc-cms-dev: echo $LANG
    en_US.UTF-8

    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_ALL=

    Continuing to dig into it.

  • edited October 11

    Opened a ticket with support about this issue. So far the response has been "You can't have two server_locale lines in iw.cfg."

    Well yes, we know that, the problem isn't that we're putting in two lines, it's that TeamSite is ADDING the second line.

    Argh.

  • You can have any color you want as long as it is black...... :-)

Sign In or Register to comment.