Java Heap Space error

 I'm getting a Java Heap Space error. In the past, I would modify the eclipse.ini file and change the Xms and Xmx values (see below). Is this the right course of action?


Change Xms256m to Xms704
Change Xmx3072 to Xmx3520


  • There are a few things to consider when modifying the eclipse.ini file to get around the Java Heap Space error.

    These are not officially recommended settings but are suggestions I came up with that generally work for most users.


    Suggestions for modifying the eclipse.ini file:

    *Note:  If you are running a 32bit operating system (OS) with a 32bit version of BIRT, it is recommended that the maximum -Xmx value be no more than 1024m due to memory limitations.  While I have been able to increase the -Xmx values up to 1536m on a clean 32bit system, it is very unlikely most users on a typical 32bit system will be able to.

    If running a 64bit OS with a 64bit version of BIRT, I've successfully run BIRT with -Xms4096m & -Xmx14336m without issues (though reserving this much memory is typically not required).


    1: Open the "%BRDPro_HOME%\eclipse\" folder and locate the "eclipse.ini" file

    Note: %BRDPro_HOME% is the location where you installed BIRT.


    2: You can increase the maximum size by modifying the "-Xmx###m" where # is the number of MB you would like to set as the Maximum. 

    Note: Increment memory slowly as too much will cause eclipse to fail to load.  Also note that 512m is recommended for machines of 4GB or less RAM, 1024m is recommended for machines with 8+GB RAM, 2048m is only useful when dealing with extremely large reports or data objects.






    3: You can increase the minimum size by modifying the "-Xms###m" where # is the number of MB you would like to set as the Minimum. 

    Note:  This generally isn't required, however if you have 8+GB RAM, you can slightly improve the general loading and design actions by increasing this number.  128m is recommended for machines with 4GB Ram, 512m for machines with 8+GB RAM.





    4: Save settings, then close and restart the designer for settings to take effect.

    Matthew L.
    Actuate is now OpenText

Sign In or Register to comment.